QT anomaly

Richard Gaskin ambassador at fourthworld.com
Thu Nov 10 16:43:00 EST 2005


I have a customer for a new app who can't load a QuickTime file, yet I
can load the same file here without difficulty, and it works well on my 
other Mac, and on our tester's Mac.

The error occurs when I set the filename of the player to the selected
file, the result returning "could not open movie file".  Not very 
descriptive, but that's all I have to go on.

I've tried the file both from my local volume and a second partition.
The customer and I have the same OS version (OS X 10.4.3) and QT version
(7.0.3), and of course the same version of the Rev-based app.

The file name is short (about 12 characters), so I can't see how it
could be related to the known issue with long file names.

To help diagnose this I made a very simple test app, with one button, 
one field, and one player, with this script in the button:

-----
on mouseUp
   if the optionKey is "down" then
     set the filename of player 1 to empty
     put empty into fld 1
     exit to top
   end if
   --
   answer file "Select a file:"
   if it is empty then exit to top
   put it into tPath
   set the filename of player 1 to tPath
   put the result into tResult
   --
   put "system="& the systemVersion &cr& "QT="& qtVersion()&cr into tData
   put "machine="&machine()&cr &"Processor="&processor()&cr after tData
   put "Result="& tResult &cr&"sysError="&sysError() after tData
   put cr & "File="& tPath after tData
   put cr& "duration="& the duration of player 1 after tData
   put tData into fld 1
   --
   put fld 1 into url 
("file:"&specialFolderPath("Desktop")&"/HT-Test-log.txt")
end mouseUp
----------


He reports the same error in this test app, with this log file:

    system=10.4.3
    QT=7.0.3
    machine=unknown
    Processor=Motorola PowerPC
    Result=could not create movie reference
    sysError=-5551
    File=/Users/xxxxxxxxxxx/Desktop/audiofile.aif
    duration=0


Any other clues as to how I might diagnose this?

--
  Richard Gaskin
  Fourth World Media Corporation
  __________________________________________________
  Rev tools and more: http://www.fourthworld.com/rev




More information about the Use-livecode mailing list