odd directory behaviour in DreamCard

Dr.John R.Vokey vokey at uleth.ca
Sun Feb 20 19:21:29 EST 2005


I wrote previously on this issue, and received Richard Gaskin's 
suggestions, below.  Neither of the cases he describes apply.  It is 
just a simple stack.  Indeed, I copied the the few lines of code to a 
new stack, and again got the same result in the player; it is as if the 
variable thePath is empty, but only in DreamCard Player, both Metacard 
and RR (latest engine versions) work correctly! It happens on both the 
Mac OS X and Windows XP versions of Dreamcard.  I'm baffled.  Any 
ideas?  I'd bugzilla this problem, but I don't have a clue how one does 
so.

> Dr.John R.Vokey wrote:
>
> > The following code works (and has always worked) in Metacard (MC), 
> and
> > Revolution (RR), both as a stack and as a standalone (and even over
> > OSs), but not in DreamCard:
> >
> > In the card script of the first card:
> >
> > global thePath
> >
> > on openCard
> >   --
> >   --  Get/Set Paths
> >   --
> >   put the filename of this stack into thePath
> >   set the itemdelimiter to "/"
> >   delete the last item of thePath
> >   -- (other irrelevant stuff deleted)
> >   set the filename of image "Test" to thePath&"/test.jpg"
> >   -- (other irrelevant stuff deleted)
> > end openCard
> >
> > In MC and RR, the path to the image is correctly specified and the 
> image
> > appears, but not in DreamCard.  Tracking it down, DreamCard sets the
> > path to the image as "/test.jpg", completely ignoring the global
> > thePath.  Why would DreamCard not set the global thePath?
>
> Is the stack downloaded or cloned?  In those cases the stack would have
> no fileName, giving the result described.
>
> Otherwise, I haven't a clue.  And even then, the behavior should not
> differ from Rev or MC.
>
> -- 
>   Richard Gaskin
>   Fourth World Media Corporation
- JRV
--
There are 10 kinds of people:  those who understand binary, and those 
who don't



More information about the Use-livecode mailing list