Com Port wait for ready character >

Camm29 Camm29 at tesco.net
Fri Dec 30 15:11:48 EST 2005


Yeah , Sorry i did look at Sarah Stack still does the same.

> Are you opening and closing the port properly? ---- IF THINK SO ?

> What kind of device are you trying to talk to?
 SOME CUSTOM HARDWARE , IT RETURNS THE CHARACTER ">" WHEN NOT BUSY AND ABLE
TO RECEIVE

> What kind of flow control/handshaking does it need? ------NONE , OTHER
THAN WAITING FOR ">" BEFORE SENDING AGAIN

> Are you handling that correctly? ---- ?

> COM1: should have quotes around it.I DON'T SEEM TO HAVE THIS , BUT I WILL
TRY

> Are the serialControlString parameters correct?----- YES , 9600 BAUD , 8
BITS , 1 STOP , NO PARITY

> Why are you waiting 250 milliseconds?----- YES , THOUGH NOT SURE IF NEEDED
IF WAITING FOR ">" WORKS

Somehow it does not always wait for ">" before sending if i put into a loop.
if i do it manually and wait for ">" to be displayed on screen it works fine
?

Regards Camm

----- Original Message -----
From: "Mark Wieder" <mwieder at ahsoftware.net>
To: "How to use Revolution" <use-revolution at lists.runrev.com>
Sent: Friday, December 30, 2005 7:53 PM
Subject: Re: Com Port wait for ready character >


> Camm29-
>
> You've posted this same message several times now.
>
> Did you look at Sarah's stack?
>
> Are you opening and closing the port properly?
> What kind of device are you trying to talk to?
> What kind of flow control/handshaking does it need?
> Are you handling that correctly?
> COM1: should have quotes around it.
> Are the serialControlString parameters correct?
> Why are you waiting 250 milliseconds?
>
> --
> -Mark Wieder
>  mwieder at ahsoftware.net
>
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-revolution
>




More information about the Use-livecode mailing list