"There was an error..."

Rob Cozens rcozens at pon.net
Thu Dec 29 10:00:34 CST 2005


Jacque,
>>I have a stack that runs fine interpretively on both Win XP (Rev 
>>2.6.1) & Mac OSX (Rev 2.1.2).  It also compiles and runs correctly 
>>on OSX. The stack is compressed & decompressed with each transfer 
>>between platforms.
>>Compiling on Windows gives me "There was an error while saving the 
>>standalone application."  That's nice to know; but it gives me 
>>little to go on to track down the error.
>>Other Windows compiles into the same folder have worked with no problem.
>>Ideas or suggestions, anyone?
>
>This gets asked a lot, so I have some boilerplate. Maybe something 
>in here will help.

Thanks for posting this, I'm saving it for future reference.

I have exorcised the bug; but don't know where or how:  I created an 
empty stack and cut & pasted between the original & new stacks.  I 
reached a point where the stacks _appeared_ to be identical except 
for the stack file name and application builder settings.  At this 
point I was still able to build standalones from the new stack; 
however, the first couple of times I tried changing the file name and 
standalone settings, I reached a state where "There was an error...."

The third time worked...mine not to reason why.

Rob Cozens, CCW
Serendipity Software Company

Vive R Revolution! 




More information about the use-livecode mailing list