More 2.5 weirdness

J. Landman Gay jacque at
Tue Sep 28 01:52:15 EDT 2004

On 9/27/04 7:38 PM, James Spencer wrote:

> On Sep 27, 2004, at 5:18 PM, J. Landman Gay wrote:
>> On 9/27/04 4:39 PM, Howard Bornstein wrote:
>>> Boy, V2.5 is now starting to act very squirly. I get into a situation
>>> where combo and popup buttons will no longer pop open. Not only the
>>> buttons on my stack, but also the buttons on the property inspector.
>>> So the little Arrow button at the top-right of the inspector no longer
>>> works, the popup, which show Basic Properties as its first choice
>>> doesn't work, etc.
>>> Most other things seem to work. This happens after my script sets the
>>> labels of some combo-buttons in my stack. That's about the only thing
>>> related that I'm doing that I can think of. Closing a stack and
>>> re-opening it doesn't fix this. I have to quit and restart Rev.
>>> Anybody seen this?
>> Yeah. In the property inspector, same as you describe, where the popup 
>> that lets you change from "basic properties" to the other sets doesn't 
>> pop down. I wasn't changing any labels on anything, so I have no clue 
>> what caused it. I haven't bugzilla'ed it yet because I can't figure 
>> out a recipe.
> I saw this for a while but like you was never able to come up with a 
> recipe so never Bugzilla'ed it.  I will say, however, that the problem 
> arose at the same time that I created a really wierd infinite recursion 
> through a preOpenStack handler in a main stack which did a time delayed 
> call to another handler which opened a different stack which did not 
> have a preOpenStack handler so the main stack's preOpenStack handler got 
> called, etc. etc. etc.  When I got rid of the recursion, my property 
> inspector worked again too although I can't begin to explain why the 
> recursion would cause the behavior I saw in the inspector.

It just happened to me again moments ago, and I wasn't doing any 
scripting. I was just trying to get properties on several selected 
objects at once so that I could align them. I don't think it has 
anything to do with scripts.

Like you, the button contents returned after a while. When it went 
south, I closed the inspector, double-clicked a single field to open the 
inspector, and it was still broken. Closed it, selected 2 objects, 
doubled-clicked on one of them, and when the inspector came back again 
the button worked. I don't think there is anything magical about 2 
objects, either -- I think there is a message that is being missed in 
the IDE.

The inspector loads its button contents dynamically when an object is 
selected, and it looks like sometimes it isn't getting a 
selectedObjectChanged message.

Jacqueline Landman Gay         |     jacque at
HyperActive Software           |

More information about the use-livecode mailing list