Getting a remote file in OS X

James.Cass at James.Cass at
Fri Sep 17 14:33:06 EDT 2004

Gregory -

Your code works for me in a button, and it retrieves the rtf file, but I 
have my firewall turned off on the host where the file is located. 
However, I have the firewall enabled on the client Mac.  Mine doesn't work 
either with the firewall turned on for the host, even when I explicitely 
allow ftp access through the firewall settings, and have passive ftp 
enabled in the Networks settings.  Try it with your firewall disabled, 
just to see if it works that way and go from there.  Sorry, not sure right 
off what to do.  Maybe a RevGuru can chime in.


Gregory Lypny <gregory.lypny at>
Sent by: use-revolution-bounces at
09/17/04 02:08 PM
Please respond to How to use Revolution
        To:     use-revolution at
        Subject:        Re: Getting a remote file in OS X

Still not working for me I'm afraid.  FTP is turned on. I also have the
firewall on.  Do I have to specify a port?  Is it because the file I
want is rtf?  Do I have to invoke some sort of library in Rev?

on mouseUp
get url
put it into fld "x"
end mouseUp


On Sep 15, 2004, at 4:09 PM, use-revolution-request at

> Do you have ftp services enabled on the Macs?  You can do this from the
> "Sharing" pane in "System Preferences".
> Please excuse this simple question if you've already done this. :-)
> This worked for me:
> on mouseUp
>   put "whateverName" into userName
>   put "whateverPassword" into password
>   put "" into ipaddress
>   get URL ("ftp://" & userName & ":" & password & "@" & ipaddress &
> "/data.txt")
>   put it into fld "x"
> end mouseUp
> Hope this helps...James
use-revolution mailing list
use-revolution at

More information about the use-livecode mailing list