openCard message not received

Richard Gaskin ambassador at fourthworld.com
Fri Oct 1 16:02:48 EDT 2004


Leston Drake wrote:
> Actually, my stack does fail in the standalone version also.
> 
> Short history >> I have been using 2.1.2 for some time now. When this 
> problem showed up, I thought it might be a RR issue, so I tried it in 
> 2.2.1. I built the standalone in 2.2.1 and it worked (the openCard 
> message was received). The next time I built it as a standalone in 
> 2.2.1, it failed. But not only did it not received the message, it had 
> the wrong text in the Caption bar of the stack (I was also seeing this 
> is 2.1.2). Rather than the Title of the stack, it showed the name of the 
> file. Going to the next card in the stack made the Title appear (?).

Sounds like something going wrong with one of the Rev script libraries 
included in the build.  It may be that the messages are locked at an 
inappropriate time, or that the libs aren't being loaded properly or 
some other initialization is stopping mid-stream during the opening 
routines.

Can you build without any additional libraries and get the same result?
Can you test with v2.5 to see if this is an old issue?

-- 
  Richard Gaskin
  Fourth World Media Corporation
  ___________________________________________________________
  Ambassador at FourthWorld.com       http://www.FourthWorld.com


More information about the Use-livecode mailing list