audio on windows not playing

C List c.list at fiberworld.nl
Thu Nov 25 16:59:21 CST 2004


It is getting stranger and weirder now.

I made small sample files of the audio file in all formats I can save to
like au, mov, avi, wav, aif. and I installed a newer version of the 
media player
and in the media player I can play everything exept the aif file.

I made a little test stack so I can pick a file for the runrev player 
to play.
The only file it can play is avi. Next I noticed it can play the file 
as long
as it is shorter than 3 min. If the track is 3.15 min I hear no sound.
The disc light shows some activity but I hear nothing. I tried this 
with the always
buffer on and off, it makes no difference.
I also tried it with another file. A cd disc track also converted to 
avi, it plays aslong
as it doesn't exceed a bit over 4 min. The file I need to play is 7.20 
min
The file is 16-bit Little Endian, stereo, 44,1 kHz, 16 bits. The 
datarate is 172.3 K bytes/sec
I also tried to downsample the file to 22,05 kHz but more than 3 mins 
it won't play.

The trouble is the audio is quite critical and compressing it to MP3 
gives to many
artifacts. (unless I find a much better compressor which I am gonna try 
next.
  I seem to be running out of options for the moment)

Tomorrow I will try setting the dontUseQt as first thing that happens, 
as Jeffrey sugested,
at the moment a couple of other routines get called first. I hope it 
makes a different but it's to weird.

best wishes
Claudi

On Thursday, November 25, 2004, at 10:26 AM, Klaus Major wrote:

> Dag Claudi
>
>> Hi Troy,
>>
>> Yes I try to play it in a player object. I also tried to play it with 
>> the
>> play "user/thisFolder/myaudioFile" command, which will sort of play 
>> the audio
>> though it will produce also the strangest cracking and distortion 
>> which is
>> absolutly unusable.
>>
>> It is also strange I have the controls set to showing and on the mac 
>> I see them
>> alright but on windows I don't see them at all. The player is just a 
>> rectangle with no controls
>> or the like.
>
> The "controller bar" is a QuickTime only feature, you get nothing on 
> windoze, obviously :-)
>
>> I wil now try importing the file (75 Mb) and see if play audioclip 
>> will work.
>
> Please don't!
>
> That will result in the same hellish noise as the "play ac ..." 
> command and indicates that
> that file is a compressed wav file...
>
> Can you open that file in QuickTime Player and check the information 
> about the fileformat?
> Maybe then we could see a bit clearer...
>
> If nothing helps, try to convert that file to e.g. MP3 format, which 
> should be playable inside
> a player even on windoze without QT...
>
>> Still hoping to find a solution
>>
>> best wishes
>> Claudi
>
> Klaus Major
> klaus at major-k.de
> http://www.major-k.de
>
>
>
> P.S.
> "player objects" versus "play ac...":
> Player objects... that use QT, which although much slower and more 
> memory intensive can
> play many more formats than the default play command which uses 
> low-level
> sound routines in Win32 and MacOS which don't support compression.
>
> Posted 9/2/2002 by Scott Raney to the MetaCard List
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> http://lists.runrev.com/mailman/listinfo/use-revolution
>



More information about the use-livecode mailing list