commands stop working when stacks call remote stacks

RGould8 at aol.com RGould8 at aol.com
Tue Nov 2 16:42:12 CST 2004


I'm getting weird behavior in Mac OS X when I've got a stack which calls a 
remote-stack.   Perhaps there's a better way to do this:

I've got a stack called "Trigger", which has a button on it.   The script for 
this button is:

on mouseUp
  open stack URL "http://download.myisp.net/MacSFPTest/events.rev"
  send "mouseUp" to button "events" of stack "events"
end mouseUp


Then, in my "events.rev" stack, which is on the server, I've got a button 
called "events" with this script:


on mouseUp
   beep
   put the name of this stack & return into field 1
   
  wait 4 seconds
   
  answer "see this popup?"
  put the effective filename of this stack after field 1
  wait 2 seconds
  beep
end mouseUp



I'm finding that Revolution 2.5 is skipping over certain commands when I run 
the "Tigger" app.   It seems to skip over any "answer" commands, and it also 
doesn't seem to like the "put the effective filename of this stack" line 
either.
If I'm running the stack in Revolution authoring mode, the mouseUp handler 
completes everything.   If I run this stack via the "Trigger" Revolution app 
which calls it remotely, it skips those 2 lines.   What's weird is that I hear 
all the beeps, so I know the script is all there.   Any idea why certain 
commands are becoming invalid when run remotely?

Any advice is greatly appreciated.


More information about the use-livecode mailing list