Running Revolution in 'other' accounts...

Phillip Thomas phillipt at gmail.com
Mon Nov 1 14:52:01 CST 2004


Hi,

I am part of a team of students who run a computing laboratory on the
University of Chicago campus. Recently, when we updated RunRev to 2.5
we have been hit with an interesting error:

Simply, put: only the user who installed RunRev is able to use it....

Specifically:  If you examine the "package contents" in MacOS X
finder, you'll find the subdirectories of Revolution.app ... relevant
one's are Contents/MacOS/  which contains the app's loading program
Revolution....   Here in lies the problem: when loading this from the
user who installed it, there are no errors (note: the file must be
executed from the App directory that contains Revolution.app...like
/Applications/Revolution\ 2.5 .... executing:
./Revolution.app/Contents/MacOS/Revolution)

However, when running from another user account (whether admin or
limited, it just simply need be not the user who installed
Revolution), there are errors when attempting to load disk fragments
of the library files containing bundled source for revdb.bundle,
revvideograbber.bundle, and revspeech.bundle, all of which can be
found in components/global\ environment/ under the application
directory...

The errors returned are code -2851 and I can find nothing concerning
this error code...it is possible that this referrence is a mistake and
meant as code -2815, which is a cyclic error (infite loop, i
presume)....

Any help is much appreciated.
Thanks,
Phillip Thomas
Maclab Tutor
University of Chicago

-- 
====================
Phillip Thomas
SigEp: VP Brotherhood Development
phillipt at gmail.com, phillipt at uchicago.edu


More information about the use-livecode mailing list