Profile issue in 2.2.1

Frank Leahy frank at backtalk.com
Wed Jul 21 06:03:00 CDT 2004


Yes, it's a bug in the 2.2.1 standalone builder.

 From Monte:

"The fix is this:
Go through all the buttons in the profile section of the General card of
revStandaloneSettings and replace "includedProfiles" with 
"includeProfiles"."

So...

1) open the Application Browser,
2) open the Standalone Settings stack,
3) select "Revolution UI Elements in List" from the View menu,
4) find the revStandaloneSettings stack in the Application Browser,
5) edit the scripts of the buttons in the "Property Profiles" section 
of the Standalone Settings General card per Monte's fix above.

-- Frank


On Jul 21, 2004, at 11:11 AM, use-revolution-request at lists.runrev.com 
wrote:

> From: Thierry Arbellot <thierry.arbellot at wanadoo.fr>
> Subject: Profile issue in 2.2.1
> To: How to use Revolution <use-revolution at lists.runrev.com>
> Message-ID: <A866D082-DAFE-11D8-A9AB-000A27E40768 at wanadoo.fr>
> Content-Type: text/plain; charset=US-ASCII; format=flowed
>
> I jut started to test Rev 2.2.1 (the 30 days trial version), and I face
> a problem while using profiles.
>
> I have a stack with 2 profiles. I use them to have different languages:
> the "Master" profile for English, a second profile, called "French",
> for French language.
>
> On MacOS X, I check the preferred language defined in the system
> preferences and switch the profile according to the language, using the
> command revSetStackFileProfile.
>
> The standalone, built using Rev 2.1, does work fine.
>
> But with Rev 2.2.1, I can't make it work.
>
> I have tried all the profile options in the new standalone settings
> "include profiles on objects and the profile library" with "include all
> profiles", also tried with "Only include profiles selected below" and
> "French", also tried "Set all objects to profile" sets to "French", but
> in all cases, the standalone is always in English, never in French.
>
> Worst, the command revSetStackFileProfile returns an error when runs in
> the standalone, but works fine from within the IDE.
>
> I suspect the profile library is not added to the standalone.
>
> Is it a new bug in 2.2.1 ? Can't find it in bugzilla.
>
> Does someone have a solution ?
>
> Thank you.
>
> Thierry
>



More information about the use-livecode mailing list