Communication with USB HID devices?

Dar Scott dsc at swcp.com
Fri Jul 9 18:50:41 CDT 2004


On Jul 9, 2004, at 4:32 PM, Phil Davis wrote:

> I haven't succeeded in opening or even copying "/dev/cu.modem" (my 
> only 'cu'
> file) yet - it hangs things up when I try. (I tried copying it to 
> Desktop
> via Terminal and via Rev 'shell' command. I also tried Rev 'put url' 
> into
> fld, but it hung.)

This should open the modem:

    open driver "/dev/cu.modem" for binary update

The driver seems to insert a 3 second delay for me in the open.

> I ran the script and it returned empty.

If your device has a serial view in addition to the HID view, then you 
should see it in either driverNames() or deviceNames().  I have seen 
some problems with serial if you can get a serial driver set up for the 
device, but there is a chance you can avoid them.  (By serial, I mean 
something that looks like an RS-232 driver, I don't mean the USB 
itself.)

I just tried deviceNames() on Panther.  It returns the built-in modem 
entry 3 times.  Weird.  (I'll check it out.)  The Revolution 
driverNames() does not return anything for the built-in modem.

> Other thoughts?

There's nothing in the control panel or someplace to make the device 
look like a mouse?

I'm running out of ideas.  If it was me, I'd be thinking of making an 
external.

Dar Scott



More information about the use-livecode mailing list