Standalone builder 2.2

Sarah Reichelt sarahr at genesearch.com.au
Fri Jul 2 02:33:30 CDT 2004


>> The startup handler never gets called in the IDE, because Revolution
>> has already started up by the time I load the stack file, but it does
>> get called in the built application. In the build or the IDE, a mouse
>> click will go to the substacks anyway, but when I want to build the
>> standalone, I open the file but don't click. Then I can build without
>> any problems.
>
> Does that mean you do have problems if these substacks are open. What 
> are
> the problems. I'd love to fix them ;-)
I tried to build when my display stack was open i.e. the first substack 
and got a message saying something like:
Can't find stack "Display"
The bundle had been built but the MacOS folder didn't exist.
I think the mainStack had only been hidden, not closed.
>
> Note that if you mean that the problem is the mainstack is closed you 
> can
> right click on the mainStack in the applicatiob browser and build from 
> there
> or build the mainstack from any substack (not from another stackFile
> though).
I'll try that again, but I think I tried it once and it didn't seem to 
do anything at all! Most of my projects have a single stack file but 
one big one has multiple files. This means it hardly ever needs 
re-building - I just put a new substack in the bundle, but when it 
does, the startup trick works well for me.

BTW none of this was meant to be criticism. The new builder is great 
and much easier to use, it just takes a bit of getting used to the new 
system.

Cheers,
Sarah



More information about the use-livecode mailing list