Why is my animation so slow on Win XP ?

Scott Rossi scott at tactilemedia.com
Sun Aug 29 20:20:15 CDT 2004


Recently, jbv wrote:

> I have a stack that begins with a (rather complex)
> 800x600 animation : controls moving around the
> screen, blendlevel of various images (gifs & pngs
> with transparency) changing slowly, etc...
> The whole thing is controled by messages being
> sent to the card 20 times per second
> (send "next_frame" to this cd in 0.02 second).
> 
> Everything runs fine & smoothly on MacOS 9.
> but on Win XP, it gets 5 to 10 times slower...
> The app seems to have especially hard times
> with modifying blendlevel of gifs or pngs...
> 
> The most surprising part of the story is that the
> Mac is a G3 / 300 MHz, while the Win box runs
> at 1.5 GHz...
> Another surprising point is that at times (roughly
> 1 time out of 10) the Win stack runs OK (as fast
> as the Mac version)...
> 
> I'm somewhat puzzled, as I'm used to the fact
> that standalones run usually significantly faster
> & smoother on Win...
> 
> Any idea ?

Part of the reason may be a low end or low memory video card.  Machine
processor speed is only one of several factors when gauging a system's
capabilities --  I believe calculating blends of images is handled by the
video card.

You might try setting the XP system's display to thousands of colors, or use
a lower resolution, and see if either change makes a difference.

Regards,

Scott Rossi
Creative Director
Tactile Media, Development & Design
-----
E: scott at tactilemedia.com
W: http://www.tactilemedia.com



More information about the use-livecode mailing list