Linux Engine: Problems on Red Hat server with CGI

Sannyasin Sivakatirswami katir at hindu.org
Thu Nov 27 13:58:31 EST 2003


Thanks for everyone's helpful responses. But our linux man couldn't 
make a go of it... he writes:

We are trying to install the MC-Rev interpreter on RH 9 at our ISP and 
believe that 4 needed files missing.  Our Linux version is:

Linux hinduismtoday.apolloservers.com 2.4.1-008stab043.15.swsoft-smp #1 
SMP Thu Mar 20 16:47:30 MSK 2003 i686 unknown

At least, we think there are 4 files missing (the 4 mentioned in the 
first section of the ldd command shown below as not found).  We tried 
linking to empty files instead, that didn't work.  The loader said the 
files were too short.  We tried alternate versions of these same files 
from other RH servers, that didn't work because, apparently, exactly 
the right versions of CXXABI_1.2 and GLIBCP_3.2 are required.  
Apparently we need exactly the files required by MC-Rev and not 
alternative versions.  We heard that MC-Rev engine didn't really use 
these shared library files and any old version or even empty files 
would work but that does not appear to solve the problem for us, 
perhaps we need more instructions?

If someone can (off list) point me to where they can be found, or ftp 
them to us, or??  Many thanks in advance.

# ldd -v /usr/local/bin/mc
        libXext.so.6 => not found
        libX11.so.6 => not found
        libstdc++.so.5 => not found
        libm.so.6 => /lib/libm.so.6 (0x4001c000)
        libgcc_s.so.1 => not found
        libc.so.6 => /lib/libc.so.6 (0x4003f000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

        Version information:
        /usr/local/bin/mc:
                libgcc_s.so.1 (GCC_3.0) => not found
                libstdc++.so.5 (CXXABI_1.2) => not found
                libstdc++.so.5 (GLIBCPP_3.2) => not found
                libm.so.6 (GLIBC_2.0) => /lib/libm.so.6
                libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
        /lib/libm.so.6:
                libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
                libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
        /lib/libc.so.6:
                ld-linux.so.2 (GLIBC_2.1.1) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.2.3) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.2) => /lib/ld-linux.so.2
                ld-linux.so.2 (GLIBC_2.0) => /lib/ld-linux.so.2

Sannyasin Sivakatirswami
Himalayan Academy Publications
at Kauai's Hindu Monastery
katir at hindu.org

www.HimalayanAcademy.com,
www.HinduismToday.com
www.Gurudeva.org
www.Hindu.org

On Nov 19, 2003, at 5:13 PM, Ken Ray wrote:

> Take a look at my foray into Linux CGIs for the two files that *I* had
> to install:
>
> http://www.sonsothunder.com/devres/revolution/revolution.htm?_cgi001
>
> The files were:
>
> libXext.so.6 and libX11.so.6.
>
> Ken Ray
> Sons of Thunder Software
> Email: kray at sonsothunder.com
> Web Site: http://www.sonsothunder.com/
>
>> -----Original Message-----
>> From: use-revolution-bounces at lists.runrev.com
>> [mailto:use-revolution-bounces at lists.runrev.com] On Behalf Of
>> J. Landman Gay
>> Sent: Wednesday, November 19, 2003 8:57 PM
>> To: How to use Revolution
>> Subject: Re: Linux Engine: Problems on Red Hat server with CGI
>>
>>
>> On 11/19/03 8:21 PM, Sannyasin Sivakatirswami wrote:
>>
>>> ##### Error log says: ######
>>>
>>> [Wed Nov 19 20:04:23 2003] [error] [client 64.75.166.210] Premature
>>> end
>>> of script headers:
>>> /home/htstore/store.hinduismtoday.com/cgi-bin/subscribe.cgi
>>> /home/htstore/store.hinduismtoday.com/cgi-bin/Linux: error
>> while loading
>>> shared libraries: libXext.so.6: cannot open shared object
>> file: No such
>>> file or directory
>>>
>>> ########
>>>
>>> Anyone know what that means? "Shared libraries: libXext.so.6" ??
>>
>> I had the same problem when I first started using cgis. It turns out
>> that not all Unix installations install the full set of
>> library files.
>> There are two in particular that Rev looks for which are often not
>> installed, and this is one of them. I can't remember the name of the
>> other, but if you get another similar error it will probably
>> include the
>> second file name.
>>
>> You can either update the Linux installation or just put in an empty
>> dummy file with the right name. Rev doesn't really read or
>> use the file,
>> it just has to be in there.
>>
>> I know virtually nothing about Linux installations, so I
>> can't tell you
>> where the file is supposed to go. My ISP installed it for me.
>> All I know
>> is that you only need an empty text file with the right name.
>>
>> -- 
>> Jacqueline Landman Gay         |     jacque at hyperactivesw.com
>> HyperActive Software           |     http://www.hyperactivesw.com
>>
>> _______________________________________________
>> use-revolution mailing list
>> use-revolution at lists.runrev.com
>> http://lists.runrev.com/mailman/listinfo/use-> revolution
>>
>
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> http://lists.runrev.com/mailman/listinfo/use-revolution
>



More information about the Use-livecode mailing list