2.1.1 better and reliable ... but

Alex Rice alex at mindlube.com
Sun Nov 2 16:13:06 CST 2003


On Nov 2, 2003, at 4:27 AM, Carsten Levin wrote:

> Yes, it is in Bugzilla, we reported it apx. 3 weeks ago, later got a  
> response that it is solved (but the solution is probably not in the  
> present download).
> You write that you dont understand the problem ...:
> "the directory"/"the defaultfolder"/"the current folder" (i dont know  
> why there are so many words for the same) is usually set to the path  
> of the Revolution Application or the Revolution Runtime/exe file  
> running the application.
> It is always the case on Mac OS.
> On Windows XP it is so, but only when running in development-mode.  
> When running in non-dev mode it is different. When doubleclicking the  
> name.rev file it is set to the path to this file. On Windows 98 it is  
> in come cases set to C:/.
> Sorry for not explaining this better in the first mail.
> This inconsistense/bug causes the solutions to fail if you have  
> desided to put some common libraries or graphics file in the folder  
> containing the Revolution application or runtime.
> You should probably see it as a problem when a development tool starts  
> to use its fundamental parts in random.
>
> But as I wrote in the first report ... I am confident that RunRev  
> knows about this and that it will be solved soon.
>

It does not appear to be fixed yet. I wouldn't be so confident until  
it's marked fixed in bugzilla.

<http://runrev.com/revolution/developers/bugdatabase/show_bug.cgi? 
id=793>


This is the command I have been using on startup to resolve the  
defaultFolder. Can anyone tell me if this bug 793 is going to effect  
me?

--
-- fixDefaultFolder
--
on fixDefaultFolder
   put the fileName of this stack into tFileName
   set the itemDelimiter to "/"
   get item 1 to -2 of tFileName
   set the defaultFolder to it
end fixDefaultFolder


Alex Rice <alex at mindlube.com> | Mindlube Software |  
<http://mindlube.com>

what a waste of thumbs that are opposable
to make machines that are disposable  -Ani DiFranco



More information about the use-livecode mailing list