Is this a bug? [was: Rogue visual effect sends rev awol]

DVGlasgow at DVGlasgow at
Mon May 26 00:30:00 EDT 2003

OK, now I am starting to panic.

Just as I am starting to burn the standalone and send it out to customers I 
get the weirdness reported  previously :

I have an assessment card that shows and hides lots of objects with visual 
effect dissolve (not QT).  When the assessment is complete, I have a continue 
button with :

on mouseUp
  visual effect reveal left
go card "results"
end mouseUp

The results card arrives with a *dissolve*, but then sits with nothing 
happenning for maybe two minutes.  During this time nothing in the Rev environment 
is doable, including cmd period.  I can swtch between finder and rev though.   

After AWOL time I get a reveal left effect to the same card, then frantic 
clicks catching up with whatever I tried during AWOL.  I assume I have stacked up 
a spare dissolve that I don't use  - (although I thought they were used last 
in first out, so to speak, no?.)

I can't for the life of me find the extra visual effect, and I have tried to 
clear it using: 

    repeat until the pendingMessages is empty
      cancel item 1 of line 1 of the pendingMessages
    end repeat

This was just a guess, assuming that 'stacked' visual effects are pending 
messages, and doesn't do the trick.

The opencard handler on the results card does have a fair bit of scripting on 
it, but this weird pause only happens if I come from the assessment card 
*having done the assessment*.  If I just navigate to the assessment card and then 
hit the continue button, all the opencard scripts execute in a fraction of a 
second and everything is responsive.

Any suggestions?  Is there a specific clear pending effects command? Or maybe 
I am barking up the wrong tree.  Any help appreciated.


It now seems I *was* barking up the wrong tree.  In the unusual absence of 
suggestions from this list, I got up early this am to wrestle with the problem 
some more.  I did the assessment (rating 60 or so images) and then rather than 
clicking the continue button which has always triggered the AWOL, I started 
the debugger.  This triggered the same extended unresponsive period.  I went and 
loaded the dishwasher, and maybe 1 minute after I got back, there was the 
cascade of delayed mouse actions and everything returned to normal.  I ran the 
continue button script in the debugger, and the results screen appeared nicely 
and the opencard script ran fine (albeit slowed down noticeably by the 
debugger).  With the debugger open in the background, I clicked a few buttons and then 
the same AWOL happened again.

I then wrote this email with characters plopping slowly onto the page - I 
guess because Rev was really busy at something.  Then suddenly, a couple of 
sentences back, there was frantic activity in the background as stuff happened in 
Rev, and everything returns to normal.

I first noticed this in a Win standalone, but develop on Mac 9.1, rev 1.1.1.  
It also happens in 2.0 rc.  

I am between professional lisences, so don't feel I can bother the Rev team, 
particularly as they are in labour just now.  On the other hand, so am I.  Why 
does this always happen when you have told your customers the software is 
ready to ship?

Best wishes,

David Glasgow
Home/ forensic assessments --> <A HREF="">
DVGlasgow </A>
Courses --> <A HREF="">i-Psych</A>

More information about the use-livecode mailing list