What happened to the cursor

Barry Levine themacguy at macosx.com
Sat May 17 15:09:00 EDT 2003


I'm not using any custom cursors. I don't even have the word "cursor" 
appearing in any script (yes, I checked). Once I read your replay, 
however, I checked whether any of the image objects in my stack are 
referencing gif's (on the odd chance that gif's used elsewhere in the 
stack might be the problem). I changed those to jpgs and modified the 
script accordingly. Same problem.

I even created a new stack of the same size and copied/pasted the 
objects from the old stack to the new one; then I copied the stack 
script into the new stack. Same problem.

The only other thing I can think of that I've changed from the older 
(working-as-a-runtime) stack to the newer (non-working-as-a-runtime) 
stack is changing the object IDs of the graphic objects. They started 
out in the "11xx" range but I changed them to 1 through 21 ("ID 1", 
etc.) in order to permit a repeat loop that sets the filenames of the 
objects (hence, the jpgs they display). Have I done a no-no? Are ID's 
in that range not to be used?

Thanks for your assistance,

On Saturday, May 17, 2003, at 10:01 AM, 
use-revolution-request at lists.runrev.com wrote:

> Message: 7
> Date: Fri, 16 May 2003 13:48:30 -0700
> Subject: Re: What happened to the cursor?
> From: Richard Gaskin <ambassador at fourthworld.com>
> To: <use-revolution at lists.runrev.com>
> Reply-To: use-revolution at lists.runrev.com
> Barry Levine wrote:
>> I built a distribution and the cursor appears as a white box. I am not
>> using any custom cursors. I've modified the stack in 2.0 and built the
>> distribution there. I also tried building the distribution using the
>> same stack but in 1.1.1. Same result. I don;t understand what's
>> happened as I've never seen this behavior before with the same stack.
>> Any suggestions would be approceiated.
> Ken and I had a go-round with Scott Raney on the issue.  It seems most
> GIF-generating tools do not reliably put the first three colors in the
> "correct" order, but the MC engine does.  This means that images 
> imported as
> cursors may show the mask instead of the image, which sounds like what
> you're seeing.
> Scott's suggestion was to create cusrors using the engine, which isn't 
> hard
> but most of us already have libraries of existing cursor images so 
> importing
> them is more desirable.
> I've found that if I just alter one pixel and set it back again using 
> the
> pencil tool, the engine resets the color table correctly for use on all
> platforms.
> -- 
>  Richard Gaskin
>  Fourth World Media Corporation
>  Developer of WebMerge 2.2: Publish any database on any site
Barry Jay Levine
"The Mac Guy"

Macintosh Troubleshooting, System Engineering, Training,
AppleShare/OSX Server Setup, System Upgrades and Enhancements,
Custom Programming for Mac/Windows/Linux/Solaris

On-Site service for K20, Business, Consumer

Phone/VoiceMail: 915-581-1105
             Fax: 915-581-8167
           eMail: themacguy at macosx.com

More information about the use-livecode mailing list