post command in 1.1.1 acting weird

kee nethery kee at
Sat May 3 23:46:01 EDT 2003

I'm doing a post to an internal web site. Basically I post, it executes 
the CGI, I get back the results in XML, and I parse and display.

This used to be 100% reliable, now it is way too unpredictable.

It worked for me this afternoon and now several hours later, it is not 
returning results. When I hit the same web page with a browser from the 
machine running revolution, no problems, instant results every time.

1. Did something change in 1.1.1 without a rev change and my version of 
revolution somehow was updated to the flakey code?

2. Is there some kind of expected response time to a post and if the 
response is just a tad too slow, the post returns before it gets 
results? If so can I lengthen the wait time for a response from a post?

I'm running MacOS X, but another on Win NT has been seeing the same 
thing for several weeks.

I've restarted Revolution, that seemed to have no effect.

I'm looking at
      postURL y,x
and when it gets to the statement where it checks
      if lvBlockingUrl is empty or lvBlockBypass is true then
and at that moment lvBlockingUrl contains a URL and lvBlockBypass is 
empty so it skips that whole section and goes to
      else ##blocked by previous request
which causes it to reply with empty

How do I clear a previous request when I know I no longer care about 
it's results? How do I know if there is an unfinished request?

URLstatus appears to only apply to FTP transfers. But even if it worked 
for what I need, I don;t see a command for clearing any existing 

I kind of think the requests are actually completed but the flags that 
say otherwise were caused by the debugging environment continuing to 
execute when it needed to be immediately halted.

Is there some global I can reset to tell revolution that all requests 
are competed?

Kee Nethery

More information about the use-livecode mailing list