Hair Pulling Time

Scott Rossi scott at tactilemedia.com
Wed Dec 31 03:32:04 EST 2003


>> Can anyone explain to me why the following script works from the
>> message box
>> and not from a mouseUp handler in a button in the same stack?
>> 
>>   choose select tool
>>   drag from topleft of img "wdm" to bottomright of img "wdm"
>> 
>> Rev returns a useless compiling error that reads:
>> 
>> Type    Function: missing '('
>> Object  Button 1
>> Line
>> Hint
> 
> I don't know what is going on.  I do see old error messages repeated at
> times.  I think they come up when error handling gets confused or has
> an error or the stack is blown.

> [snip]

Thanks for the suggestions.

I haven't used try/catch in a ling time, but I'm not sure this will solve
the problem.  No error is caused by running the script: Rev chooses the
select tool and then wanders off somewhere without drawing the selection
marquis.  There's no script error generated.  Changing the handler to
keyDown has the same result.  Restarted Rev, isolated to a simple test
stack, still same result.

The script runs as expected from the message box and within MetaCard so it
seems to be an IDE thing.  [sigh] No hair left...

Regards,

Scott Rossi
Creative Director
Tactile Media, Multimedia & Design
-----
E: scott at tactilemedia.com
W: http://www.tactilemedia.com



More information about the Use-livecode mailing list