OSX Pinstripes and Modeless Mode

Jan Schenkel janschenkel at yahoo.com
Thu Dec 11 17:52:13 CST 2003


--- "J. Landman Gay" <jacque at hyperactivesw.com> wrote:
> On 12/10/03 11:40 PM, David Egbert wrote:
> 
> > I've been using modeless to open stacks so that
> they have the pinstripes
> > seen in MacOS 10.1 & 10.2.  Everything looks great
> in development, but when
> > I build the stacks as standalones modeless shows a
> grey background instead
> > of the pinstripes (I'm in 10.2.8). Is there a
> library or something that
> > needs to be included?
> 
> Interesting. Sounds a little like the same loss I
> experienced where the 
> background pattern disappeared in standalones. I
> thought it was the 
> Distribution Builder at fault, but maybe it is
> something else. Sorry, I 
> don't have a clue what it could be, but I get a gut
> feeling the problems 
> are related. You might want to bug-report it.
> 
> -- 
> Jacqueline Landman Gay


Hi Jacque,

Did you check the box "Apply default colors" ?
When the DB script was still open, I disected the
source code, and remember that on some platforms, the
DB will set the backgroundColor to certain values ;
and when both a backgroundPattern and backgroundColor
are set, the backgroundCOlor is what matters.
That might explain it, or I need more sleep :-)

Jan Schenkel.

=====
"As we grow older, we grow both wiser and more foolish at the same time."  (La Rochefoucauld)

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree


More information about the use-livecode mailing list