assign by reference - a comment

Ken Ray kray at sonsothunder.com
Sat Mar 23 18:20:01 EST 2002


Sorry, Dar, I don't like adding in "variable" into the mix... it just
confuses things. Why not just call it what it is: a pointer. Instead of
"put" (as we have for assignment), how about "point", as in:

   point <var1> to <var2>

So if you said "point myVar to hisVar", you have the real variable in
"hisVar" and the pointer in "myVar". Personally, I'd use more realisting
names to get the point home, like if I had a local variable called
"scoreCount", I might say:

   point scoreCountPtr to scoreCount

But you get the idea...

Ken Ray
Sons of Thunder Software
Email: kray at sonsothunder.com
Web site: http://www.sonsothunder.com/

----- Original Message -----
From: "Dar Scott" <dsc at swcp.com>
To: <use-revolution at lists.runrev.com>
Sent: Saturday, March 23, 2002 5:03 PM
Subject: Re: assign by reference - a comment


>
> On Saturday, March 23, 2002, at 10:58 AM, Rob Cozens wrote:
>
> > While I favor support for pointers, handles, etc.  that does NOT
> > mean I support their implementation in Xtalk with cryptic @ or @@
> > syntax al la C.  Any support for these features should fit
> > naturally into Xtalk: eg "get the address of someVariable" seems
> > natural for a pointer.
>
> How about...
>
> put the id of variable oneVariable into pointerToVariable
> put the "blah blah" into variable ID pointerToVariable
>
> Dar
>
>
>
> _______________________________________________
> use-revolution mailing list
> use-revolution at lists.runrev.com
> http://lists.runrev.com/mailman/listinfo/use-revolution
>




More information about the use-livecode mailing list