Animated GIF strangeness

Barry Levine themacguy at macosx.com
Fri Dec 13 20:40:10 EST 2002


Wondering if anyone has encountered this situation..

I have an image object to which I have assigned the filename of a 
particular GIF. The path is fine; the GIF does appear. As the GIF is 
animated, I use the properties box to set a repeatCount of 1. When I 
close the saved stack and re-open it (leaving Rev running), the GIF 
appears as it should. However, if I quit Rev (after saving) and 
re-launch/re-open the stack, the GIF sits a frame 1. When I examine the 
properties of the image object, the repeatCount has, somehow, been 
reset to 0. If I build a distribution of the stack (after first 
verifying that the repeatcount is correct), the compiled app also has 
the GIF sitting at frame 1. If I set the repeatCount to -1, it does 
repeat forever. If I set the repeatCount to 2 or 3, it gets set back to 
0 as described above, as well.

I worked around the problem by using a QT Player object and simply 
added a "start player..." line to the openCard script but it concerns 
me that such strangeness has appeared. I had used another GIF earlier 
(in the same image object) and it worked perfectly. The "bad" GIF was 
created by another individual using Illustrator for each frame (and 
"saving for web") and then using GifFun to assemble the frames. I even 
tried converting the GIF with GraphicConvertor just in case something 
was wrong with the original (and hoping GC would be able to fix it - as 
it usually does work miracles). No luck.

Is there a GIF spec I need to convey back to the GIF producer? I've 
used other GIFs in my stacks and have had no problems. I've been using 
iDraw to create and assemble the whole thing (while my GIF producer has 
all of his original art in Illustrator). Coulc this be a case of too 
many colors? (I'm grasping at straws.) Or maybe this is a "fixed in 
Rev2.0" thing ans I should simply be patient.

Thanks,
Barry




More information about the Use-livecode mailing list